gemot encubed  

Go Back   gemot encubed > Gemot > Production & Help

Production & Help For discussions regarding production aspects, especially localisation, of visual novels and related games.

Reply
 
Thread Tools Display Modes
  #1  
Old 2010-09-09, 17:21
Yume no Hana's Avatar
Yume no Hana Yume no Hana is offline
Regular
 
Join Date: May 2010
Posts: 41
Default KiriKiri engine and Unicode Fonts in Windows 7

Excuse me, my friend is translating Sharin no Kuni and he has some problem with unicode fonts.
After modifying marco.ks, he was finally able to make the engine run unicode font in Windows XP but Windows 7 seems to be much more difficult...
(the best fonts that support my language are Times New Roman or other unicode fonts, non-unicode fonts can't be used with Kiri Kiri engine at all)
If you know solutions to this problem, please let me know. I'll be very grateful.

Last edited by Yume no Hana; 2010-09-09 at 17:32.
Reply With Quote
  #2  
Old 2010-09-09, 21:27
Message's Avatar
Message Message is offline
Obsessive
 
Join Date: Dec 2003
Location: Netherlands
Posts: 323
Default

You can work around the font restrictions in krkr by modifying the font to pretend that it's unicode. Or Japanese, more specifically. I don't know the exact details, but I'll ask the guy who does to give some details.
Reply With Quote
  #3  
Old 2010-09-09, 22:33
dsp2003
Guest
 
Posts: n/a
Default

You can also patch the executable to disable Unicode-only font restriction. Here's a good example (use Google Translate if needed): http://honyaku-subs.ru/forums/viewtopic.php?f=17&t=134
Reply With Quote
  #4  
Old 2010-09-11, 00:36
ArchDemon
Guest
 
Posts: n/a
Default

Here's a quick way to fix the problem that involves editing the fonts themselves rather than the game or executable.

1. Download High-Logic Font Creator which you can download here (30-day trial version, unrestricted).

2. Open the font you want to edit (e.g. Times New Roman, but I recommend using a free font and not a commercial one).

3. Click Format, Settings, select the Ranges tab, then click Edit... in the Code Page Character Ranges section and uncheck all the checkboxes while checking JIS/Japan (932), then click OK, then click OK again.

4. Click Format, Naming, click Windows Unicode BMP (UCS-2) and change the names in the Naming sections where applicable, then click OK.

5. Then click File, Save As..., then name the file whatever you like (e.g. newfont.ttf) and click Save.

Then just install that into your Windows fonts section and it should show up in the KiriKiri2 engine for any game.

Some fonts might look ugly, so it might take you a few tries to see which fonts look good.

~ArchDemon
Reply With Quote
  #5  
Old 2010-09-13, 21:47
deltaxix
Guest
 
Posts: n/a
Default

Thanks all of you very much. I'll try it now .^^.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kirikiri2 Unicode Unregistered Technical Issues 4 2011-09-06 23:05
RealLive Fonts ? Miteno Technical Issues 6 2008-12-25 00:27
How can I output Unicode characters in Majiro engine game? majiro Technical Issues 0 2007-05-22 11:20
About scripts and fonts Unregistered Technical Issues 10 2007-01-17 12:26
How can I run kirikiri engine in Korean window except changing non-unicode settings kirikiri Technical Issues 22 2007-01-01 04:09


All times are GMT -8. The time now is 15:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.