gemot encubed  

Go Back   gemot encubed > Gemot > Technical Issues

Technical Issues For bug reports, problem solving, and help running Japanese software.

Reply
 
Thread Tools Display Modes
  #1  
Old 2009-08-02, 07:48
ritchan ritchan is offline
Member
 
Join Date: Feb 2008
Posts: 11
Default Compiling ONScripter-EN-20080823

Hello, I'm trying to compile Haeleth's onscripter on IRIX using MIPSPro cc and as and ld from the GNU binutils collection. I get this error when compiling smpeg:
Code:
as: Error: /usr/people/shinichi/source/onscripter-en-20080823/extlib/src/smpeg/video/mmxflags_asm.S, line 54: must give attribute values for new section
     .section .note.GNU-stack,"",%progbits
gmake[1]: *** [mmxflags_asm.lo] Fehler 1
gmake: *** [extlib/bin/smpeg-config] Fehler 2
The offensive section:
Code:
#ifdef __ELF__
.section .note.GNU-stack,"",%progbits
#endif
So it seems to be a syntax problem, yet it compiles (not cleanly, warnings from other parts of smpeg) on my x86 Gentoo system. I've ascertained that I am using the GNU as. Is there something I should add to the code? What does .section by itself mean anyway? From what I read online, the syntax should be .section[name]...
Reply With Quote
  #2  
Old 2009-08-02, 22:46
Roto
Guest
 
Posts: n/a
Default

It looks like it's trying to compile MMX-related stuff, which obviously won't work on MIPS. You can poke at Hæleϸ's configuration scripts to try to fix it so that it configures properly for your system, but I'd recommend just compiling all of the dependencies separately, installing them on your system, and then using those instead of using the internal libraries provided with ONScripter-en.
Reply With Quote
  #3  
Old 2009-08-03, 15:12
ritchan ritchan is offline
Member
 
Join Date: Feb 2008
Posts: 11
Default

I managed to get it to compile on AIX 6.1, easier since I used GCC (GCC apparently makes better code for POWER than it does for MIPS). Screenshot soon. I'm downloading some stuff from al|together 2008 to test this, hopefully they're NScripter.

Oh, and I tried to get Saya no Uta working, but I couldn't get my head past the .pak files. Is it really a NScripter novel?
Reply With Quote
  #4  
Old 2009-08-03, 15:22
ritchan ritchan is offline
Member
 
Join Date: Feb 2008
Posts: 11
Default

[shinichi@monolith:LEAVEs] ./onscripter-en
setkinsoku: "vxjnpABCDEHIRSTUX[","uwimo"
Setting English mode based on filename
Adding: .
Adding: ..
And it just uses around 33% kernel and 17% user CPU and doesn't display a window. Anybody care to guess what's going on here? At first I thought maybe insufficient privileges to access video, but when I ran it as root, the same thing happened.
Reply With Quote
  #5  
Old 2009-08-03, 15:42
ritchan ritchan is offline
Member
 
Join Date: Feb 2008
Posts: 11
Default


196kb is too small for an image!

So I found that the ONScripter version included with LEAVEs was two weeks newer than the 20080823 version I compiled. So I downloaded OMGWTFOTL from al|together 2006.

Fullscreen doesn't scale the image, you just get a small square surrounded by borders. That seems to be a common thing on every Unix I've used. As you can see, sound isn't working. I don't know what to do about it, because XMMS now refuses to start on my machine (must be because I upgraded glib or gtk). I'll have to get XMMS working again to confirm that sound is working on my machine before I get around to sound for ONScripter.

Now I have to admit, I'm getting out of my bounds here. I don't know jack shit about programming, I just took a 1 semester course in C programming... twice. So please don't ask me to code up some sound module for AIX, because I can't.

Last edited by ritchan; 2009-08-03 at 15:52.
Reply With Quote
  #6  
Old 2009-08-03, 16:01
ritchan ritchan is offline
Member
 
Join Date: Feb 2008
Posts: 11
Default


I've got to admit, even though Narcissu is old, it looks really professional. I'm real happy it runs.
Reply With Quote
  #7  
Old 2009-08-03, 17:14
ritchan ritchan is offline
Member
 
Join Date: Feb 2008
Posts: 11
Default

Sound now works. Turns out because the system SDL_mixer installed from perzl.org/aix depends on esound, I just had to run esd and it'd work. Dunno why I forgot about that.

Also, it seems the ONScripter can terminate unexpectedly. All it says is:
Quote:
X connection to :0.0 broken (explicit kill or server shutdown).
Reply With Quote
  #8  
Old 2009-08-04, 03:25
ritchan ritchan is offline
Member
 
Join Date: Feb 2008
Posts: 11
Default

So I compiled the latest version on ONScripter:
Quote:
[shinichi@monolith:[WH] Umineko English] ./onscripter --version
setkinsoku: "vxjnpABCDEHIRSTUX[","uwimo"
ONScripter version 20090718-en (2.92)
Written by Ogapee <ogapee@aqua.dti2.ne.jp>

Copyright (c) 2001-2006 Ogapee.
This is free software; see the source for copying conditions.
However the same thing persists... LEAVEs stalls at 'Adding ., Adding ..' and the English patch for Umineko4 says it still can't find any/all BGM files, despite the BGM filenames being stored in UTF8. Of course, I've ensured that all BGM files are present:

Quote:
[shinichi@monolith:umineko4] ls BGM
00_cage_take3.ogg death(from stupefaction).ogg tsurupeta-128.ogg
02_stupefaction.ogg dir.ogg u2_nighteyes.ogg
03_play.ogg discode1c.ogg u2_黒のリリアナ.ogg
07_voiceless.ogg dreamenddischarger.ogg where-02.ogg
08_deadangle.ogg far.ogg wingless.ogg
09_suspicion.ogg gc-01.ogg worldenddominator.ogg
0b_worldenddominator.ogg happiness of marionette_omake.ogg あかいくつ偽.ogg
10_witch_in_gold_cenba.ogg happiness of marionette.ogg くるり.ogg
11a_worldend.ogg happy_maria_uta_m.ogg さくたろうの頑張り物語り.ogg
11b_worldend_solo.ogg haze.ogg ひだまり.ogg
26_dive to emergency.ogg hibuta.ogg エンドレスナイン(リズム付き).ogg
599 million ruins.ogg hope(Ver1.00).ogg オルガン小曲_第2億番_ハ短調.ogg
Answer.ogg maria_utanasi_mx.ogg オルガン小曲_第6億番_ハ短調.ogg
Answer_short.ogg mind_2.ogg ロウソクたちが踊る.ogg
As time goes by.ogg minute darkness.ogg 久遠.ogg
Closed My Heart.ogg miragecoordinator.ogg 休息.ogg
Dread of the grave -More fear-.ogg moon.ogg 問い詰め.ogg
Dread of the grave -rhythm ver-.ogg mortal stampede.ogg 夏の扉.ogg
Dread of the grave.ogg mother.ogg 失楽園.ogg
F Style.ogg novelette.ogg 暗闇の刻.ogg
Fortitude.ogg over.ogg 月うさぎの舞踏.ogg
HANE.ogg prison.ogg 煉沙回廊mu.ogg
Haruka.ogg psy-chorus.ogg 煉獄凶狂葬曲.ogg
Like the gale.ogg rahu_goldenslaughterer.ogg 犯行の予告状読み上げ(ラック眼力).ogg
M4.ogg rhythm-changer.ogg 生まれてきてくれてありがとう.ogg
Melting away.ogg rougoku.ogg 痕音.ogg
Monochrome Clock.ogg sakura.ogg 白い影.ogg
Parallel.ogg sasorinoharawata.ogg 白日夢の果て_age.ogg
Red Dread.ogg sea.ogg 神秘の森.ogg
Revolt.ogg shika_long.ogg 絵画の魔女.ogg
Ride on(飛行機に乗って島に行くときのイメージ).ogg sirabe_mx.ogg 翼.ogg
Surrounding.ogg sirabe_oche.ogg 誘い.ogg
Towering cloud in summer.ogg slowmotion.ogg 踊る煙官.ogg
UmiNeko C FINALMIX_01.ogg soul of soul.ogg 隣死 mu.ogg
Victima_propiciatoria.ogg sy.ogg 黄金の影修正版(ラック眼力).ogg
activepain.ogg system0.ogg Requiem.ogg
ageha.ogg tekuteku.ogg
apathy.ogg tsubaki.ogg
Any help would be appreciated.
Reply With Quote
  #9  
Old 2009-08-04, 03:55
ritchan ritchan is offline
Member
 
Join Date: Feb 2008
Posts: 11
Default

Fixed LEAVEs... apparently once I removed game.id, the window suddenly sprung up. I assume it's because of the different line breaks between Windows and Unix (CR+LF vs LF), which confused my compiled onscripter to no end. To test, I made an empty game.id. Onscripter hung again. I edited it with vi. Because vi inserts a LF, it works.

Last edited by ritchan; 2009-08-04 at 04:16.
Reply With Quote
  #10  
Old 2009-08-04, 04:02
ritchan ritchan is offline
Member
 
Join Date: Feb 2008
Posts: 11
Default

Quote:
[shinichi@monolith:english] ./onscripter-en
setkinsoku: "vxjnpABCDEHIRSTUX[","uwimo"
Setting English mode based on filename
Adding: .
Adding: ..
Adding: /home/shinichi/.Umineko4final/
Adding: ./:../
command [harbor] is not supported yet!!
command [errorsave] is not supported yet!!
addkinsoku: "h","g"
Setup layer effect for 'snow.dll'.
Quitting...
Maybe it's because of this harbor thing... syntax error perhaps? Running onscripter in the top directory of umineko4 results in the Japanese version working correctly, so perhaps...
Reply With Quote
  #11  
Old 2009-08-04, 05:15
ritchan ritchan is offline
Member
 
Join Date: Feb 2008
Posts: 11
Default

I managed to get it to work by using the ONSlaught tools (crypt.exe) to extract 0.txt from the nscript.dat, and using a text encoding converter to convert the entire script from Shift_JIS to UTF8, then re-xor84-ing it back into a nscript.dat. The resulting nscript.dat doesn't work with the binary provided in the Umineko4 patch for Windows. The opening water drop sound works, I can hear the seagulls crying at the title screen, but once I start an episode, the BGM becomes static noise.



As you can see, the opening video plays perfectly, with working audio, 50% utilization on both POWER4 cores. However, BGM music has become static noise. Is something wrong with vorbisfile? I can hear when the BGM ends and is repeated... but then it repeats and I hear static again. At this point, when I return to the title screen, the seagulls have become static noise as well.
EDIT: It seems that not only that, the seagulls are playing at twice their speed because esd is fixed at 44kHz while the .wav files that comprise sound effects in Umineko are 22kHz. The Vorbis BGM is in 44kHz, but surely that couldn't have resulted in static. All the other VNs I tested were using mp3s.

Now the question is: how are vorbis files played? Is libvorbis doing the decoding? If so, then how do I fix it?

Last edited by ritchan; 2009-08-04 at 05:40.
Reply With Quote
  #12  
Old 2009-08-04, 15:13
Sonozaki Futago-tachi
Guest
 
Posts: n/a
Default

Hi ritchan,

Sorry I didn't see this thread sooner. Have you tried compiling the current ONScripter-EN from http://svn.haeleth.net/onscr/trunk/ ? It fixes a lot of issues. Of course I can't be sure how well it will compile for you, but please give it a try.

Mion (Sonozaki Futago-tachi)
Reply With Quote
  #13  
Old 2009-08-04, 15:16
ritchan ritchan is offline
Member
 
Join Date: Feb 2008
Posts: 11
Default

Yes I have, in fact, the last 3 screenshots were taken with the SVN ONScripter-EN. I think the problem lies with my system's libvorbis, so I'm compiling with --with-internal-libs passed to configure, although that has problems of its own. Will post those later.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with compiling xclannad for Windows Mobile Zer0_byt3 Technical Issues 5 2011-06-28 05:03
Problems compiling xkanon Freakker Technical Issues 16 2005-12-09 12:31


All times are GMT -8. The time now is 04:15.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.