gemot encubed  

Go Back   gemot encubed > Gemot > Technical Issues

Technical Issues For bug reports, problem solving, and help running Japanese software.

Poll: mRnyWwiEXLZzHvICJm
Poll Options
mRnyWwiEXLZzHvICJm

Reply
 
Thread Tools Display Modes
  #1  
Old 2006-07-01, 05:55
Konomii
Guest
 
Posts: n/a
Default Sorry,may I ask a question about RLDEV?

Hello, this is Konomii.
I am translating a sort of game named Bokura wa minna koi wo suru

And hope it can be outputted the translation and input the game directly.
But I have not much idea about the usage of RLDEV.

Could you please teach me? Sorry to bother you.
And by the way, I know how to output. Put “seen.txt” into

Code:
“kprl -d seen.txt -o seendir -f 1.40”
Then outputs the “seen~.ke” and the files with extension “. utf”
And may I ask how should I translate and edit back to “seen.txt”
with “complier” after editing the files and translating into Chinese, please?

Will REALLIVE engine support “UTF-8”code? How about coding with “ANSI”,please?

Thank you
Reply With Quote
  #2  
Old 2006-07-01, 06:01
Haeleth's Avatar
Haeleth Haeleth is offline
Ex-boss
 
Join Date: Mar 2003
Location: England
Posts: 2,106
Default

RealLive itself only supports Shift_JIS, but RLdev comes with a little trick that lets you use GB2312 (Simplified Chinese) instead. You must edit files in UTF-8, using ordinary Chinese text; then when you compile them RLdev converts them to its own encoding that can hold most Chinese characters, and then a RealLive plugin called rlBabel is used to display Chinese text when you play the game.

You probably have to add an "-e utf8" to that to get .utf output.

After that, translate into Chinese, save in UTF-8 format, and then compile the files with
Code:
rlc -e utf8 -x chinese (filename)
.

Then copy the TXT files you get from that into the game folder, and then download this and this and put those in the game folder too.

Then open gameexe.ini in a text editor and add the line
Code:
#DLL.000="rlBabel"
somewhere.

You should then be able to run the game and it should work in Chinese. There are a lot of complications along the way, so feel free to ask if anything doesn't work or if you need more help. :)
Reply With Quote
  #3  
Old 2006-07-01, 06:34
KONOMII
Guest
 
Posts: n/a
Default

Thanks for your reply^_^

After
“rlc -e utf8 -x seen1010.utf -v 1.40”’

compiling, It says
“Error: unknown output transformation `seen1010.utf'.”
May I ask u how to deal with it,please?
Reply With Quote
  #4  
Old 2006-07-01, 06:46
KONOMII
Guest
 
Posts: n/a
Default

Sorry,I use this "rlc -e utf8 -x chinese seen1010.utf -v 1.40 -o abc.txt"
this time,but it said

Rlc 1.40: RealLive-compatible compiler
Copyright (C) 2006 Haeleth

[snip: rlc usage information]

I don't know what I should do^^;;
Reply With Quote
  #5  
Old 2006-07-01, 07:34
Konomii
Guest
 
Posts: n/a
Default

Sorry, I reply too times.
I have a mistake. I forgot put the rlc to the game directory.
I have a problem this time.
it said..

E:\pekoe\bokura>rlc -e utf8 -x chinese seendir\seen1010.utf
Error (seen1010.utf line 14): invalid character 0x5c in source file.

It seems can't support chinese..
line 14 is

<0001> \ てすとね、ぼくのおうち、引っ越すんだって。\p\n

sorry,sir.
Reply With Quote
  #6  
Old 2006-07-01, 15:25
Haeleth's Avatar
Haeleth Haeleth is offline
Ex-boss
 
Join Date: Mar 2003
Location: England
Posts: 2,106
Default

This is the problem:
Quote:
rlc -e utf8 -x chinese seendir\seen1010.utf
You are trying to compile the text resource file. Instead, you should compile the game source code that uses that text:
Code:
rlc -e utf8 -x chinese -f 1.4 seendir\seen1010.ke
By the way, I just realised: you might need to use two copies of the rlBabel files (rlBabel.dll and 1.4.0.5.map), one in the game folder and one in the REALLIVEDATA folder.
Reply With Quote
  #7  
Old 2006-07-01, 15:44
Konomii
Guest
 
Posts: n/a
Default Konomii

Thanks^^ Sorry,My English is so poor.
May I use Japanese^^;;

I change that now.

but "CHINESE" code have some problem now.
Code:
bin\rlc -e utf8 -x chinese seendir\seen1010.ke
It said
Quote:
E:\pekoe\bokura>bin\rlc -e utf8 -x chinese seendir\seen1010.ke
Warning (SEEN1010.utf line 13): cannot represent U+30fc in RealLive bytecode
with the `Chinese' transformation of GB2312.
Error: unable to encode the character U+9854. Check input and output encoding
settings.
But,My Chinese Text is not wrong....
UTF-8 Text,Chinese..What should I do?

If I use the '.sjis' (Not UTF-8) , not error.
If I use the ' chinese/utf' It will be error.

and if I use the sjis,it can't use chinese. 'seen1010.txt' will be created.
that means if I use the command right?

Code:
bin\rlc seendir\seen1010.ke
but It said 'Fatal error: exception Sys_error("Permission denied")'
I put the ’rlBabel.dll' in game folder,1.4.0.5.map in the reallive data folder.
have same problem><

Sorry><
Reply With Quote
  #8  
Old 2006-07-01, 15:47
Konomii
Guest
 
Posts: n/a
Default Re: Konomii

これです^^;
Code:
bin\kprl -a seendir\seen1010.txt
Reply With Quote
  #9  
Old 2006-07-01, 19:40
Konomii
Guest
 
Posts: n/a
Default Re: Konomii

I am OK! I can make that.
but I hope can support 'Traditional Chinese'.
and support all character set><

Thank you.
Reply With Quote
  #10  
Old 2006-07-02, 03:27
Konomii
Guest
 
Posts: n/a
Default Re: Konomii



SELECT TEXT can't display correct ><
Is select text=NAMAEbase text?
That's source (ke)
<0068> {山吹琴耶}(有点吃不消……该怎麽办啊)\p
<0069> 抵抗
<0070> 温柔地推开
<0071> 放弃

And I also want to release the traditional chinese, can you support that^^;
Reply With Quote
  #11  
Old 2006-07-02, 14:04
Haeleth's Avatar
Haeleth Haeleth is offline
Ex-boss
 
Join Date: Mar 2003
Location: England
Posts: 2,106
Default Re: Konomii

Quote:
Originally Posted by Konomii
Thanks^^ Sorry,My English is so poor.
May I use Japanese^^;;
もしそのほうが易しければ、どうぞ日本語で~
(でも、コノミィさんの英語は私の日本語よりずっと上手みたいですね・・・)

Quote:
Originally Posted by Konomii
It said
Quote:
E:\pekoe\bokura>bin\rlc -e utf8 -x chinese seendir\seen1010.ke
Warning (SEEN1010.utf line 13): cannot represent U+30fc in RealLive bytecode with the `Chinese' transformation of GB2312.
Error: unable to encode the character U+9854. Check input and output encoding settings.
But,My Chinese Text is not wrong....
UTF-8 Text,Chinese..What should I do?
The problem here is with the character you are encoding. It says the problem is with "U+9854". If we look that up (here), we can see that it's the character 顔, which is not a Simplified Chinese character. :)

Currently, Traditional Chinese is not supported at all. I can add support, but it will take a while. Sorry.

Quote:
Originally Posted by Konomii
I put the ’rlBabel.dll' in game folder,1.4.0.5.map in the reallive data folder.
To be absolutely safe, put both in both places. :)

Quote:
Originally Posted by Konomii
SELECT TEXT can't display correct ><
Well done! This time you've found a bug in rlc. ^^;

Download the fixed rlc.exe from here and overwrite your old one with it, and this should work.
Reply With Quote
  #12  
Old 2006-07-02, 17:30
Konomii
Guest
 
Posts: n/a
Default Re: Konomii

ご迷惑を掛けてすいませんでした。
繁体字中国語をサポートしてくれてありがとうございます:)

選択の部分は直りました^^
あとは、REALLIVEの部分ですが...
ゲームをスキップするとき、一部のシナリオは文字化になっちゃいました^^

gam