View Single Post
  #4  
Old 2008-04-04, 10:26
Haeleth's Avatar
Haeleth Haeleth is offline
Ex-boss
 
Join Date: Mar 2003
Location: England
Posts: 2,106
Default

The "deprecated conversion" error relates to a change in gcc 4.2, which is stricter in how it handles string constants; the code compiles fine with gcc 4.1 (the default in Ubuntu 7.10). I've fixed it in SVN to behave nicely with 4.2's tightened rules. Be aware that there's some of Mion's experimental stuff in the trunk right now that hasn't been tested extensively; the workaround for people who don't fancy being guinea-pigs is to disable errors on warnings as the OP suggested.

I haven't managed to duplicate the vorbisfile problem in Ubuntu; I'll try some other distros when I have a chance. I will suggest that a generic workaround for library-related problems is to try the bundled versions, which are less likely to suffer from inter-distro variation.

As for "20080121-0ubuntu1 from the repositories", it looks like it was compiled without English support, so best to reserve it for Japanese gaming.

Last edited by Haeleth; 2008-04-04 at 10:32.
Reply With Quote