gemot encubed  

Go Back   gemot encubed > Gemot > Technical Issues

Technical Issues For bug reports, problem solving, and help running Japanese software.

Closed Thread
 
Thread Tools Display Modes
  #1  
Old 2003-12-27, 14:53
Guest
 
Posts: n/a
Default I need help with Neugier for the Super Famicom

First of all, my apologies since this is probably an uber newbie and very stuipid kind of question... But does the patch works on the newest version of Snes9X or is it my rom? I have tried to around five times in a row and all I get is a black screen. I have done it in the two possible ways being by patching the rom and by using the built in pre patching system in the emulator, yet still doesn't work. Can someone fill me in? u.u
  #2  
Old 2003-12-27, 16:20
Haeleth's Avatar
Haeleth Haeleth is offline
Ex-boss
 
Join Date: Mar 2003
Location: England
Posts: 2,106
Default

Well, I just tried it and it works for me (patch version 1.10, Snes9x version 1.42 for Windows). Sounds like troubleshooting time.

When you first load the ROM in Snes9x, it should display the following message at the bottom of the screen:
Quote:
"Neugier (tr. Haeleth)" [checksum ok] LoROM, 8Mbits, Type: ROM+RAM+BAT, Mode: 20, TV: NTSC, S-RAM: 2KB, ROMId: ???? Company: A0 CRC32: E408604A
When you load the unpatched Japanese ROM, it should display a similar message:
Quote:
"NEUGIER" [checksum ok] LoROM, 8Mbits, Type: ROM+RAM+BAT, Mode: 20, TV: NTSC, S-RAM: 2KB, ROMId: ???? Company: A0 CRC32: 7F0DDCCF
  • If both messages are correct, then the problem is with Snes9x.
  • If the text displayed for the original ROM is correct, but the text for the patched ROM is wrong, then the problem is with the patch.
  • If the text is wrong for the original ROM as well, then the problem is your ROM.
Hopefully that should narrow it down a bit.
  #3  
Old 2003-12-27, 16:52
Guest
 
Posts: n/a
Default

It seems to be a problem with the patch itself, but I find that strange. I have tried the patch available at The Whirlpool and the one on your site. So chances is that it could my emulator as well. Although it isn't the rom since it works perfectly unpatched in my emulator. Hmm. Do you have any other suggestions?
  #4  
Old 2003-12-28, 06:43
Haeleth's Avatar
Haeleth Haeleth is offline
Ex-boss
 
Join Date: Mar 2003
Location: England
Posts: 2,106
Default

One possibility that springs to mind is that your ROM, while good, may be different from the one I have, which will naturally cause problems when patching.

The most likely difference is that your ROM may lack a header, while the patch assumes that a header is present. Easy to check - just look at the size of the file. If it's 1,049,088 bytes, it has a header; if it's 1,048,576 bytes, it doesn't. In that case, use SNESTOOL to add a header to it (answer N to both questions); you can find SNESTOOL by following the links from the Whirlpool's FAQ.

If that doesn't help, please download SMC.COM (also linked from the Whirlpool's FAQ) and post the output you get when you run it on the unpatched ROM.
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help regarding .po files In0kz Production & Help 0 2013-12-05 07:00
Super Robot Taisen = Visual Novel? DragonmasterX General Discussion 2 2010-03-05 15:10
Need help about Higurashi chula General Discussion 13 2008-03-30 06:46
Need help with Castle Fantasia ButtercupSaiyan Technical Issues 2 2007-04-16 04:52
Famicom Detective Club Haeleth General Discussion 14 2004-11-08 16:01


All times are GMT -8. The time now is 05:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.