gemot encubed  

Go Back   gemot encubed > Gemot > Technical Issues

Technical Issues For bug reports, problem solving, and help running Japanese software.

Reply
 
Thread Tools Display Modes
  #1  
Old 2007-01-25, 12:09
Orb's Avatar
Orb Orb is offline
Visitor
 
Join Date: Jan 2007
Posts: 3
Default Can't apply English Planetarian correctly

Today I bought Planetarian (actually I did it twice by accident), downloaded it, finally installed it (had a lot of trouble with that because they've changed the purchasing/installation/launching process, and btw it costs 300 yen more now) - had to make the "BuddySetup306.exe" compatible with Windows 2000 - then applied the English patch made by insani/haeleth and.. It didn't work.

The Japanese version, w/o the patch, works. I can start the game, begin it, the logo appears, the music starts to play, etc.

The English version starts. The main menu is in English now and there's an extra button "load game", however there are no saved games. I press "start game", a chime rings, and.. This is it. There are two points on the screen, like that: "..", there's an inactive menu below, I can right-click and call the right-click menu, but whatever I do, I can't get past this screen.

What should I do to fix that??


P.S. I post here because the last post on the insani's forum is ~1 year old.
Reply With Quote
  #2  
Old 2007-01-25, 12:47
Misu's Avatar
Misu Misu is offline
Addicted
 
Join Date: Oct 2004
Location: Bellevue, WA
Posts: 862
Send a message via AIM to Misu Send a message via MSN to Misu Send a message via Yahoo to Misu
Default

Its sounds like either A) You don't have East Asian language support installed on your system or B) your missing the specific font that Planetarian uses. I can't remember what the name of that font was off the top of my head, but if you do a search of the technical forums here for Planetarian, the you should be able to find it.
__________________
VisualNews
Reply With Quote
  #3  
Old 2007-01-25, 13:35
Orb's Avatar
Orb Orb is offline
Visitor
 
Join Date: Jan 2007
Posts: 3
Default

Hmm.. No, I have the Japanese settings on my system right now (locale, default language, default date settings, east asian languages support).
As for that font - I have installed but the very same problem persists. I've also tried the patch for Windows 98 - but it didn't work too.

My system's configuration.. I have Windows XP.. Planetarian is installed in C:\Program Files\planetarian (I've tried different directories). I have also installed the "Buddy" program by Interlex which was required to run the game (it verifies the registration). It asks for an update (though I have downloaded the version right from https://www2.bgamebox.com/info_playmanual.htm - the site where I downloaded the game (http://www.kineticnovel.jp/ redirects there for the game purchasing), however when I say "Please do", it hangs on 0%; if I say "Do not", the game launches as I have described. The Japanese version runs OK. The English patched version doesn't.

That's what the screen looks like right after I click "start game" and the screen darkens with a chime:


This is how it looks without the patch.



Added: if I load the game from the patched English version, it hangs the same way, only now the screen is black.




Oops.. Sorry!! It does run :D

Evidently, the problem was in the video from the beginning!! (the first video where it says "This is from Key" or something and the second video where a girl talks something about the planetarium and the city is beautiful and shiny)
Now I've loaded the second bookmark and it is OK.. (It starts with "10000 days later" or something like that) And English works too :)

..that was difficult for me to solve. Anyway, that was probably because they have altered the game a bit now.

Last edited by Orb; 2007-01-25 at 13:41. Reason: Not to double-post
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Planetarian English patch not working... eternal Technical Issues 5 2007-10-26 09:37


All times are GMT -8. The time now is 20:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.