PDA

View Full Version : Linux Installation HELP?


Andrico
2007-06-20, 12:46
Linux newbie here, recently upgraded from M$ Windows XP, and I have no clue how to run this terminal. So far all I've figured out on my own is [su]. Would someone give be the code that I have to run to install the files for Linux? I have what I want downloaded, and I know that it's a .tar.bz2 file, but I don't know whether I should configure it or what. help? Thanks in advance.

Roto
2007-06-20, 17:30
Which game are you trying to run?

The games available for download from VisualNews that are marked as x86 linux each have a precompiled version of onscripter. So, you'll want to extract the archive, put it where you want, and then run the "onscripter" program that was in the archive. For example, say you downloaded Adagio. You would do the following:

tar xjf 'AdagioSetup[insani][AT2006].tar.bz2'
cd Adagio
./onscripter

which would start running the game.

Andrico
2007-06-21, 12:30
I'm planning on installing basically every game that is offered for Linux, but also want to know how to install Second Life :-)

Ok, here are the error codes I get:

tar: AdagioSetup[insani][AT2006].tar.bz2: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
[root@localhost ~]# cd Adagio
-bash: cd: Adagio: No such file or directory

And then, with Instant Deat! Panda Samurai, I can un-archive it I can't get any farther than that. I've tried this with root and non-root accessw, so I know it's not that.

Misu
2007-06-21, 14:25
Well, are you sure your in the right directory?
Cause the error is telling you that in the directory you are in at the moment you ran tar xjf 'AdagioSetup[insani][AT2006].tar.bz2' is not where Adiago was downloaded to. You have to be in the same directory that you downloaded Adiago to to run just tar xjf 'filename.exe' without specifying the full path.

So, why dont you try running ls in the directory your in and see if there is a file called AdagioSetup[insani][AT2006].tar.bz2. If there is not, thats where the problem is and you have to navigate yourself to where you downloaded Adiago, then run the tar command there.

Hope that helps.

(And if you cant find the file, try redownloading it and watching where it goes..., and if you still can't find it, tell us what OS and browser you used to download it on and we can probably guess where the file should reside after a default download).

Oh, and just a little opinion thing..., if your a Linux newbie just moving from MS Windows XP and your not terribly familiar with shell environments, I would highly suggest starting yourself off with a Linux that has a nice graphical interface for it (GUI) preinstalled, so you can first get accustomed to how Linux works and its quirks before full jumping into shell to learn that. Theres a bunch of good free versions of Linux you can download out there with good GUIs (Ubuntu, SUSE, Fedora Core, PCLinuxOS, MEPIS, ect...).

Roto
2007-06-21, 15:24
Also, another thing you can do (once you're in the correct directory) is to type 'tar xjf ' and then start typing the name of the file; then hit tab. If what you've typed so far uniquely identifies a file in the current directory, it will be autocompleted. Since it won't autocomplete if the file's not there, it can be a good indication to you that you're in the wrong place before you've bothered to type out a big, long filename. It also ensures that characters like the square brackets (which have special meaning to the shell) are properly escaped (i.e. prefixed with backslashes) when the autocompletion happens, so you don't have to put it in single quotes.

And, if some of the files you've downloaded are .tar.gz or .tgz files instead of .tar.bz2, use 'tar xzf' instead. (If you have a brand new distribution of Linux, you may be able to just do 'tar xf' for everything, but it's only the very latest version of tar that will detect the compression type properly.

And in case you don't know, 'cd directory' is the change directory command, and 'pwd' tells you where you happen to be at the moment. 'ls' lists the files in the current directory.

If you're using a Linux distro with a good GUI like Misu recommends, there should also be a graphical archive manager tool that you might want to look for. Double-clicking on the .tar.bz2 file might even bring it up automatically for you, but Linux distributions vary so it's hard to say for sure.

Misu
2007-06-21, 15:31
Oh, and one last thing that confuses some windows porters, cd.. does not work in Linux to go down one directory as it is incorrect (MS Dos incorrectly interprets the statement). The proper way to write it is cd .. and Linux fully understands that as the command to go down one directory.

Andrico
2007-06-21, 19:37
lol, yeah, I'm using FC6, so the GUI is not the issue. So, I figured out was wrong with the last one, but now I get the problem:
ONScripter version 20050923a(2.54)
can't open any of 0.txt or 00.txt or nscript.dat or nscript.___
I get that with both Adaigo and A Winter's Tale.
What am I doing wrong? Or is there a problem with the OS or something.

Roto
2007-06-21, 20:07
Hmm, that's odd. You're in the directory that contains either 0.txt or nscript.dat, right? (i.e. don't try to move just the onscripter binary to another directory by itself, and make sure that the directory with 0.txt or nscript.dat is the working directory.)

If that still doesn't work, try 'onscripter -r .'

Andrico
2007-06-29, 14:19
Oh dear.... still having problems... At least it's not as bad as the stuff I had with io back on Windows. Never got that figured out. Ok, so here's what I get:

[root@localhost ~]# cd '/home/andrico/Adagio/'
[root@localhost Adagio]# ./onscripter
ONScripter version 20060724-insani(2.55)
Floating point exception
[root@localhost Adagio]#

And then: Nothing. I also tried using the GUI to click on the onscripter file, and I still get nothing. So then I try and use a different one.

[root@localhost ~]$ cd '/home/andrico/a_winters_tale/'
[root@localhost a_winters_tale]$ ./onscripter
ONScripter version 20050923a(2.54)
can't open any of 0.txt or 00.txt or nscript.dat or nscript.___
[root@localhost a_winters_tale]$

This is the same as I used to get. So then I try and download a few new ones. I start with Night of Forget Me Nots. I unpack this one and I don't even need to use the terminal, I just click on the program after extraction and away it goes, so YAY! But I'm not done yet, because I am game deprived without Windows and with Wine being a piece, so I try Plain Song. On Plain Song, I can't even open the archive manager, which is a problem I only had before with .rar archives until I figured that out. So then, I got the command line output:

bzip2: Compressed file ends unexpectedly;
perhaps it is corrupted? *Possible* reason follows.
bzip2: Inappropriate ioctl for device
Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.

/bin/gtar: Unexpected EOF in archive
/bin/gtar: Error is not recoverable: exiting now

I try Instant Death: Panda Samurai, which doesn't really matter as much to me cuz I beat it on Windows, and I got the exact same problem as Adaigo. So then I try Visions from the Other Side. Same problem as Adaigo. And then I try, Red Shift and A Winter's Tail, and I get the same problem as Plain Song. So right now, I've only been able to get one to work. Any advice? Cuz I really love Visual Novels, and the sooner I can do this, the sooner I can figure out how to get Casual Romance Club running.

Andrico
2007-07-05, 18:15
bump? Anyone? At All?

zalas
2007-07-05, 18:57
Do me a favor and run 'ls -lR' inside ~/Adagio

Andrico
2007-07-09, 01:11
.:
total 11756
-rw-r--r-- 1 L L 11656 Aug 15 2006 0.txt
-rw-r--r-- 1 L L 3346825 Aug 15 2006 arc.nsa
-rw-r--r-- 1 L L 3670052 Aug 15 2006 default.ttf
-rw-r--r-- 1 L L 18322 Aug 15 2006 GPL.txt
-rwxr-xr-x 1 L L 4917140 Aug 15 2006 onscripter
-rw-r--r-- 1 L L 6587 Aug 15 2006 PFSL.txt
-rw-r--r-- 1 L L 1395 Aug 15 2006 readme.txt

As shown, ./onscripter was green. What significance is this? Oh, yeah, I got both games in "I too saw dreams through air" running.