PDA

View Full Version : Planetarian DRM question


Zvezda
2006-03-20, 15:51
Back in December, I bought planetarian. It worked great, and I loved it. You guys did an awesome job translating and everything.

My question is basically this: I've had to reinstall the program twice within the last 24 hours (Reasons why below). This second time, however, when I go in to download it, the download button is greyed out. The kana says something about contacting customer support (My japanese isn't that good), and so I'm wondering if it's set up such that you can only A) Download and get your 'key' (no pun intended) once per 24 hours or something, or B) Only get your 'key' twice before you have to purchase it again. In advance, thanks for the help.

---
Some technical information that might be helpful:

On Saturday, I reinstalled windows on my laptop (to fix some driver problems it had been had been having). This is where it gets complicated.

I had kept the origional installation file from when I downloaded Planetarian, realizing that one day I would probably need it for when I decided to reinstall. Also, before I formatted my C drive, I coppied the planetarian directory out of the Program Files directory on my C drive, thinking that maybe, by some grace of God, Planetarian would still work after I reinstalled if I simply put it back where it was. Sadly, it didn't, and I keep thinking that it wanted me to go through the DRM authentication again. As I didn't yet have japanese text support installed, I didn't know what it was saying, and so I simply removed all the Planetarian files except my savefiles, and then reinstalled from the origional .exe file.

Going through DRM authentication again, it popped up a window, taking me to what was basically this (https://bbs.drm-center.com/Pfus0030?cid=Pcus0090&First=First) page (though it had a bunch of other variables/junk in the URL, which makes me wonder if that had something to do with resetting my DRM stuff), where I re-downloaded planetarian (the button was not at that time greyed out), and reinstalled using the file I just downloaded. Going through DRM again, everything worked out, and the program ran successfully.


Today, much to my dismay, I realized that windows had messed my partitions up, which was preventing me from installing linux (For some reason, the windows install put the main windows partition inside of an extended partition that didn't even begin at the first sector on the hard disk). I wasn't too pleased, and so I grabbed the planetarian files out of Program Files again, this time making sure to get the HKEY_LOCAL_MACHINE->SOFTWARE->ezRights registry key(s), thinking that maybe it would work THIS time (Hey, it worked for photoshop 7). Sadly, it didn't, and now when I try to go through DRM on the files I do have, it just pops up an internet explorer window with an invalid URL (that looks nothing at all like what a normal URL should). Logging into https://bbs.drm-center.com/Pfus0030?cid=Pcus0090&First=First doesn't quite work either, as my 'download' button is now greyed out. This sucks, because now Revvie is broken, my files are broken, and I have no way to get the install file again. Damn. If any of you guys know the answer, I'd certainly appreciate hearing it.

Haeleth
2006-03-20, 16:57
Do you think you could post some screenshots of the various error messages and suchlike? I appreciate the detailed description of the issues, but truly, a picture is worth a thousand words, and the exact Japanese text may well contain the answer. :)

Zvezda
2006-03-20, 17:46
That's the basic problem. I was (miraculously) able to find a backup copy of the origional planetarian install file. It still won't let me get a new key, though.

Here's the basic process I go through:


which results in...


I'm almost certain that that last picture is a result of the registry key I saved, though. When I reinstall Planetarian using the origional file and repeat the above process, it'll take me here:


Which, after logging in, produces exactly this (again):




Thanks, btw.

Zvezda
2006-03-20, 17:50
Actually, when I go through using the (proper) installation method, It gives me a slightly different message:

Haeleth
2006-03-21, 03:03
What happens if you use the ライセンスキー再発行 ("reissue license key") button next to the greyed-out download button on the site? That seems to be what the message in the most recent dialog box is suggesting.

Zvezda
2006-03-21, 07:06
Clicking on that takes me to this screen:


The bottom button takes you back to the screen I was just at (the one you get after login), while the top button takes you here:


Down near the bottom of that page, there is a link:

When you click on it, takes you here:


Not sure what's going on there.

Haeleth
2006-03-24, 16:56
Hmm, the answer isn't obvious, I have to confess. :/

It does appear that the "download" button being greyed out is a problem that you would normally have to contact customer support about. But of course they explicitly don't offer any support to overseas customers...

Zvezda
2006-03-24, 17:21
Yeah, I suspect that they either only allow two downloads/registrations, or you only get to download/register once every 90 days or something. Thanks for the help. We'll see what ends up happening.

Nanatuha
2006-03-27, 02:25
Well, I may be wrong, but don't those error numbers mean network error numbers? 0404(not found) and 0408(request timeout)
It seems your software can't be connecting to license server for some reason. Isn't Anti-virus software or something blocking connection?

Billhead
2006-03-27, 11:23
If they are HTTP error codes, the timeout would make sense if it was a firewall/anti-virus getting in the way, but I've never had a firewall or content filter ever give me a false 404 error, they always just timeout insted.

Zvezda
2006-03-28, 09:22
Setting my computer up as the DMZ host behind my router and turning off my windows firewall/antivirus have no effect. It still returns a 404.

Zvezda
2006-03-28, 11:38
What the hell, that was weird.

I went back onto the website and basically used the method you would use if you were going to buy the game for the first time, except I logged in with my username/password where you would ordinarily sign up for your account (at the top). After that I accepted their license agreement, and then said to myself, nah, I really don't want to spend another $10. I closed the window before the next page even loaded, and then suddenly Thunderbird informed me that I had a new e-mail from them. Acting on a hunch, I went through the DRM thing again, and lo and behold, it reg'd successfully. Logging back into my account, I see that my download button is still greyed out. All I can say is that I hope they didn't charge me another $10 :P

Um, I'm declaring this fixed? I think?

o_O

Billhead
2006-03-28, 13:05
Off topic, but is your username russian?
Звезда?

Zvezda
2006-03-28, 14:27
Ya, it literally translates to 'star' if I'm not mistaken.