PDA

View Full Version : Errors installing


bbcjoke
2004-06-01, 05:39
Hi there, I just got the Kanon Game (due to the animes series, the original PC one) but I think I'm having problems installing it. It only creates two folders in the diretory I install the game (besides the other files, of course): DAT and PDT, but if I go and check in the windows XP registry (yeah, I'm using windows XP) it mentions the following folders: KOE, MOV, BGM and SAV (this last one I think it does not exist because I still haven't saved a single game). The fact is, the game works but it does not have a single sound effect. I've tried already everything listed here, and came to the conclusion that I DO need the BGM folder... so can someone check for me if it exists and post here the answer please?

Haeleth
2004-06-01, 07:38
KOE, MOV, and BGM are used by other AVG32 games for voice data, movies, and MIDI/wav music, but Kanon doesn't have any of those: you aren't missing anything.

When you say "no sound effects", what are you referring to specifically?

Sorry if this is going over stuff you've tried already, but if you're not hearing music, or you're hearing it but it's not changing, look at the third section here (http://haeleth.net/kanon.html#Windows); also check that your CD-ROM drive is set up to play CD audio (you may have to disable digital output). If you're hearing music, but not any sound effects, check your wave playback settings (do the .WAV files in the DAT folder play back when you double-click them in Explorer?).

bbcjoke
2004-06-01, 17:15
Actually, the problem is the BGM (background music), not the sound effects. I've tried the third section already, but no sucess. And hum, how do I disable the audio output?
And... when is the first time I can hear a BGM?

Haeleth
2004-06-02, 02:51
The music should be starting as soon as you reach the main menu, and from then on there's barely a moment without it.

I know it sounds silly to ask, but can you play audio CDs normally in your CD-ROM drive? If they won't play at all, check the volume isn't muted (hey, it happens!), and then try disabling digital output: the option is Control Panel -> System -> Hardware -> Device Manager -> DVD/CD ROM drives -> (double-click the drive in question) -> Properties -> Enable digital CD audio.

If that fails, have you tried __inmm.dll? Stranger's written a guide to using it which you can find here (http://forums.haeleth.net/viewtopic.php?t=33&start=33).

Edit: Sudden horrible thought - you have got your Kanon CD in the drive while you're playing, right?

bbcjoke
2004-06-03, 04:46
Lol, yes I have it in my CD drive... I came to the conclusion that I am missing something. Since I didn't get the CD from a store but from an anime event, there is a possibility it is not original, and it may have been ripped. Anyway, thanks for the help.

K
2004-06-03, 14:49
I've heard that certain pirated copies of the game do indeed lack the music... dunno if that's the problem, though.

Try popping the CD into a CD player and seeing if it has more than one track.

zalas
2004-06-05, 11:04
Also, see if you have an audio cable between your cdrom drive and your sound card. Some of the newer computers (prepackaged ones) don't do this, and have the digital output enabled by defauilt. Cheap bastards...

bbcjoke
2004-06-06, 09:45
At last, I have sound!
The problem was my sound card itself. Now I got a new one. Thanks for your help guys!