View Full Version : Help with Little Busters! Tools

2014-07-20, 15:53
Ok, good to be back to the action here!

Wrapping things simply: Our translation group wants to translate Little Busters! to our home language, and while I have had some experience with RLDev tools, LB! works with another version that, apparently, isn't supported by 2006's Healeth tools. Searching a little more, I found out a rather hideous method for these tools be compatible, with some modifications, involving having a virtual machine and a lot of configurations (link (http://www.baka-tsuki.org/project/index.php?title=OCamlInstall)). I spent quite some hours working on that, but it always gives some kind of error that doesn't allow the commands to work. During the last set of configurations (right before installing OMakefiles, which is the next-to-last step), it terminated the compilation as it is missing a library (png.h). After some search, I found that library and included it manualy, but then it asked me more of those libraries (zlib, zconf, pngconf), and finally, after putting all those, it still gives me another error, saying:

(...)cannot find -lpng
(...)cannot find -lz
collect2: error: ld returned 1 exit status
Error during linking

I've followed every step on the tutorial at least four times each, and still no luck when it gets here. I've tried to search for those "pre-configured" files or just something that could help overcome this, but as far as I went, all I got were vague answers.

If someone more experienced (or one who participated on a translation project of LB! to english or another language) can show me what am I doing wrong, by all means, it would help me very much!

Notes (that might be useful):
- I'm running a 32-bit XP OS
- I've selected all files to download on cygwin, both in binary and source codes
- All the other steps, as far as I'm concerned, haven't got any warning or persistent error.
- I'm trying to translate the classic Little Busters game, not EX or PE.
- With RLDev 1.40 I've managed to extract the files in SEEN.TXT for translation, but to compile it again, it somehow doesn't read the gameexe.ini (error in first line) and stops dead.
- I've tried installing cygwin without a virtual machine, but it gives more errors at earlier stages.
- I don't understand (much) programming as I'm no hacker (wish I was, tho)

EDIT: Btw, sorry for posting on the wrong section, just realized that now -.-

2014-09-07, 23:20
We have realized that the new Designer iPhone 6 Cases (http://www.e6case.com/Designer-iPhone-6-Cases-e6case1-379.html) group would be the top seller this year again.