PDA

View Full Version : .ARC help


Niokun
2012-01-31, 16:15
So, I'm currently translating Da Capo to portuguese and I'm running into some issues here.

I managed to extract the scripts and translate/repack them with no problems. Only thing is, when I repack them to .ARC extension, the game itself refuses to run. I already tried putting one scenario script alone in the game's root folder and executed the game and it shows the text perfectly, but once I replace the .ARC (in this case, data01000.arc file), the game no longer runs.

I'm kind of at lost here. I'm using bgi tools to do the repackaging. One thing I noticed is that the original game's data01000 is around 2mb, and the repackaged file is around 8mb. Is that what's causing my problem? Anyone here have a lead of how to solve this issue? Please?

EcchiLord
2012-02-01, 09:36
Well, you could try to use AnimED (http://wks.arai-kibou.ru/ae.php?p=dl) tool to repack the resources, since i'm doing shuffle! translation to portuguese as well, and i got no problems like that using this tool.

You can also try this another BGI Tools (http://www.mediafire.com/?lmjjojzwhzm), but i didn't test those (it appears to be command line tools).

Niokun
2012-02-02, 06:47
That bgitools you sent me was the exact same one I have in my computer. Plus, I tested it once again and got the same error...

I could use animED, sure, thing is (this will sound extremely noob now) I don't know how to use it. Either if I run it as admin or not, it shows I must start the program on a "saner" OS, like Windows XP. I use 7, so I don't know if it affects the program... as if it wasn't enough, I did started the program on XP, and guess what, I got the same message again.

Searching around a bit more, I discovered a tool called arc_conv, and it has support for our game's engine (both Shuffle! and Da Capo)...but I also don't know how to use it since the creator of the software is Russian, so I don't even know what's written in the program's forums. So far I just worked out how to extract the .arc file, but no luck on repacking it again =(

Can you help me how to solve this? Have any ideas?
Thx for replying fast btw ^^

arkady18
2012-02-02, 07:04
Either if I run it as admin or not, it shows I must start the program on a "saner" OS, like Windows XP. I use 7, so I don't know if it affects the program... as if it wasn't enough, I did started the program on XP, and guess what, I got the same message again.
It's just that dsp2003 & friends hate Vista and 7. Don't worry: it works fine and well. Just click OK and the program starts. Then you have to click on the left arrow to go to the section named "Archive Tool" and you can enjoy the program.

I'm not too familiar with Arc_conv but if you extract all the files in its archive you will see a txt called "formats.txt". There you can read how it works, as it's explained only in English.

Niokun
2012-02-02, 10:06
Oh....I see, haven't seen that option before.

Nevertheless, I'm still facing the same problem. AnimED identifies the file format as ethornell/bgi with no problems, so I selected that option and created the .arc archieve once again from the extracted folder (by the same program), but the game still refuses to run...

A friend of mine said that the Da Capo game somehow detects changes in its .arc files, and if it detects one, it simply blocks the .exe, meaning no game until the original .arc is put back...Is it true or am I doing something really wrong here?

arkady18
2012-02-02, 10:12
I don't know what to say. I've never managed to make a BGI game accept a new archive. I only know that it recognizes your files if you drop them in the game folder.

EcchiLord
2012-02-02, 10:39
Well, i been looking through some pages on internet and i think i found a answer. I don't know if its allowed to post link to other forums here, so i just copy & paste from there, check it out:

It's because they added checksums for the archives themselves from within the script. It's less of a matter of the exe and more of a matter of the initial _bp script checking the archive. In this case, in system.arc, you have ipl._bp, which checks the hashes of the data archives (hashing function is at 401000, trace from there). If someone is willing to make a disassembler/reassembler, this problem could be overcome. It can also be overcome by manually patching in the hashes, but that's probably too much of a pain for most people.
(Function at 0045B6D0 in the new exe is the one doing the hashing). With a few clever hardware breakpoints, it's possible to find the location of the hashes, but I think a _bp disassembler/reassembler would solve these problems once and for all.

Now, i'm not a programmer, so i don't understand very well, but i think is just what you said, the game verifies all archives before start, so if any of them have been modified, the game get blocked.

Try dissassembling ipl._bp and see if you can find out about the checksum function, and if even is possible to remove it, like it was said in the quote from the other forum.

Niokun
2012-02-04, 19:02
Thx everyone for the help, now I did it even without even getting to modify checksums ^^

In short, in the end, I couldn't delete the checksum entirely, but I could bypass it by making it check the original file first, but reading the scripts in another file. That way, the checksum will always be true when the game launches and it will always read the translated scripts.

Just like in this photo:
http://i1032.photobucket.com/albums/a408/niokun/this.png?t=1328410784